Install of Ubuntu 8.10 server unbootable (solved)

Mark Kirkwood markir at
Fri Dec 26 23:07:17 UTC 2008

I wrote:
> Attempting software raid again, unfortunately no joy at all - firmly 
> refuses to boot. I think I am running into a variant of these initramfs 
> bugs:
> However none of the work-arounds suggested there work (sleep in 
> initramfs-tools/init and adding break=mount),
Finally figured this out. I had run into *two* bugs that were working 
together very effectively to confuse me!

1/ dmraid enenabled in the initramfs.

This appears to be the default... despite the fact I choose to have it 
*disabled whilst installing* (hmm... I think that's a new bug to raise). 
With this card I need to define at least 1 fake array to boot off in the 
BIOS, and with dmraid enabled, it used this, stealing 2 of my disks from 
the md arrays, thereby breaking them...

The solution I used was to boot from the cd into "rescue broken system" 
and remove dmraid (I'd guess it can be done more elegantly... but I'm 
happy to remove the guy):

$ sudo aptitude remove dmraid

2/ md arrays not assembled by the time system tries to use them

This is the situation covered in the bugs mentioned previously, I worked 
around this by using one of the suggestions mentioned therein:

$ sudo -i
# cd /usr/share/initramfs-tools/scripts/init-premount
# echo "/sbin/udevadm settle --timeout=10" >> udev
# update-initramfs -k all -u

So now we boot at last. I'll go and raise a bug about 1/ (unless I find 
it already in the bug database).

Finally I've made such a mess of this installation with all the things 
I've tried, I'll redo it again to have a clean initial setup, plus I'd 
like to tweak the chunksize with the md arrays (didn't see any way to do 
this from the installer - might have to use the rescue cd 1st...).



More information about the ubuntu-users mailing list