Install of Ubuntu 8.10 server unbootable (a measure of progress)

Mark Kirkwood markir at
Fri Dec 26 02:04:22 UTC 2008

Mark Kirkwood wrote:
> Since the nice installer seems to know about drivers for the TX4000 card 
> I decided to try Promise firmware RAID - with the same result - busybox 
> prompt. Oh dear. However, exiting out of busybox resulted in the boot 
> continuing (seemingly) normally.
> Hmmm - I tried removing 'splash' and 'quiet' from the kernel command 
> line, and this gets things a bit further... looks to be hanging 
> detecting/probing the CDROM drive now.
> So, at least I've managed to boot the beast! I'll update everything to 
> the latest version, and see if that helps.

No, it didn't, but seeing what was happening with more verbose boot 
messages (i.e removing quiet), prompted me to be much more aggressive 
with the rootdelay kernel line option (rootdelay=300) - so my command 
line looks like:

$ cat /proc/cmdline
root=/dev/mapper/pdc_bcfcjihecj3 ro vga=791 rootdelay=300

Now, that was too high, but allowed a boot without any problems. So we 
are sorted (for hardware raid anyway). I might go back and try software 
raid now I have more idea what the problem was!



More information about the ubuntu-users mailing list