Anyone with problems upgrading alsa driver on Hardy 2.6.24 kernel?

Frans ketelaars at
Mon Dec 22 20:03:02 UTC 2008

On Sun, 21 Dec 2008 19:11:16 +0100, Nigel Henry wrote:

> I'm having a problem with "make" complaining when trying to upgrade the
> alsa driver on Hardy 8.04's 2.6.24 kernel, and make throws in the towel
> after only a few lines of output.
> I get the same problem on my Debian Etch install with a 2.6.24 etchnhalf
> kernel.
> On the face of it, it looks like a problem with 2.6.24 kernels, as on
> Dapper with a 1.0.15 kernel, and alsa driver 1.0.10, where I had no
> sounds, I was able to upgrade the alsa driver to 1.0.15, and then had
> sounds. On my Etch install with a 2.6.18-6 kernel, with alsa driver
> 1.0.12rc1, no sounds, but was able also to upgrade to the 1.0.15 alsa
> driver, and then the sounds worked.
> I've also just tried upgrading the alsa driver on my Ubuntu 8.10
> install, with a 2.6.27-7-generic kernel. No complaints from "make", and
> ran to completion. I've havn't run "make install", as the sounds are
> working ok with the 1.0.17 alsa driver, and I'm sure that as "make" has
> run to completion,  "make install" will also run to completion,
> resulting in alsa driver 1.0.17 being upgraded to 1.0.18a.
> All the above is on the same machine. Asus M2N-X Plus mobo, with hda
> intel "Azalia" soundcard, using a ALC662 codec.
> The sounds are working on Hardy's 2.6.24 kernel, and since I commented
> out the model option for the hda intel card on Etch, the sounds are
> working for the 2.6.24 etchnhalf kernel as well.
> This is perhaps a bit academic as sounds are working, but I'm puzzled as
> to why "make" is complaining on 2.6.24 kernels.
> So if anyone has been able to upgrade the alsa driver on Hardy's 2.6.24
> kernel, I'd be gratefull for any feedback.
> I'll post the output from the "make" fails if required.
> Thanks for any help.
> Nigel.

I get this:

frans at frans-desktop-ubuntu:~/alsa-driver-1.0.18a$ make


make[1]: Leaving directory `/home/frans/alsa-driver-1.0.18a'
make -C /lib/modules/2.6.24-22-generic/build SUBDIRS=/home/frans/alsa-
driver-1.0.18a  CPP="gcc -E" CC="gcc" modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-22-generic'
  CC [M]  /home/frans/alsa-driver-1.0.18a/acore/hrtimer.o
In file included from /home/frans/alsa-driver-1.0.18a/acore/hrtimer.c:2:
/home/frans/alsa-driver-1.0.18a/acore/../alsa-kernel/core/hrtimer.c: In 
function ‘snd_hrtimer_callback’:
error: implicit declaration of function ‘hrtimer_forward_now’
make[3]: *** [/home/frans/alsa-driver-1.0.18a/acore/hrtimer.o] Error 1
make[2]: *** [/home/frans/alsa-driver-1.0.18a/acore] Error 2
make[1]: *** [_module_/home/frans/alsa-driver-1.0.18a] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-22-generic'
make: *** [compile] Error 2
frans at frans-desktop-ubuntu:~/alsa-driver-1.0.18a$ uname -r
frans at frans-desktop-ubuntu:~/alsa-driver-1.0.18a$ 

HTH :-)


More information about the ubuntu-users mailing list