SSH file mounting is dropping and crashing

Edward Ludlow eludlow at
Mon Dec 22 10:12:40 UTC 2008

I have a directory that I mount a remote file system into, using SSHFS. 
I have a script which creates and then removes a directory in the 
mounted folder every minute so as to hopefully keep the SSH connection 

However, randomly the connection still drops out - sometimes it's 
happened within minutes of the connection being established, other times 
it can happily stay connected for a few days.

The big problem when this happens is that the directory to which I mount 
then becomes totally unusable unless I reboot the server. By unusable, I 
mean it can't be accessed, changed, removed or anything. This hasn't 
been a huge problem (annoyance aside...) all the time I've been at work 
5 days a week, but with being about to go on leave for a fortnight, it's 
going to be a bit more of a pain....don't want to keep SSHing onto the 
server from the mountains whilst skiing to reboot the server!

An ls -alh shows the following:

d????????? ? ?    ?       ?                ? mount

Once I reboot it's fine and ownership is back with me. Have obviously 
tried editing / removing it as root, but still no luck.

Any idea what is wrong?

Ed Ludlow

More information about the ubuntu-users mailing list