gksudo just sleeps, exits without displaying anything and without error

martin f krafft madduck at madduck.net
Sat Dec 20 14:41:32 UTC 2008


Hi folks,

I am experiencing a strange problem with gksudo on an 8.10
installation. If I run something like 'gksudo synaptic' from
a terminal, the command seems to sleep for 3-5 seconds and then
returns with exit code 0. However, no password prompt was displayed,
and synaptic did not get started.

  ruth at brick:~$ gksudo -d synaptic
  No ask_pass set, using default!
  xauth: /tmp/libgksu-3luujN/.Xauthority
  STARTUP_ID: gksu/synaptic/9641-0-brick_TIME811463820
  cmd[0]: /usr/bin/sudo
  cmd[1]: -H
  cmd[2]: -S
  cmd[3]: -p
  cmd[4]: GNOME_SUDO_PASS
  cmd[5]: -u
  cmd[6]: root
  cmd[7]: --
  cmd[8]: synaptic
  buffer: -sudo: sorry, you must have a tty to run sudo-
  buffer: --
  [...]
  brute force GNOME_SUDO_PASS ended...
  No password prompt found; we'll assume we don't need a password.
  xauth: /tmp/libgksu-3luujN/.Xauthority
  xauth_env: (null)
  dir: /tmp/libgksu-3luujN

The culprit seems to be that sudo does not find the tty to run, but
there is definitely one. If I run the command manually:

  sudo -H -S -p GNOME_SUDO_PASS -u root -- synaptic

no such error is printed.

Any idea what could be going on?

-- 
martin;              (greetings from the heart of the sun.)
  \____ echo mailto: !#^."<*>"|tr "<*> mailto:" net at madduck
 
there are two groups of people in the world: those who believe that
the world can be divided into two groups of people, and those who
don't.
 
spamtraps: madduck.bogus at madduck.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: digital_signature_gpg.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature (see http://martin-krafft.net/gpg/)
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20081220/2b9adaa7/attachment.pgp>


More information about the ubuntu-users mailing list