Another networking problem

John French cjf at
Thu Dec 11 17:14:51 UTC 2008

Mark Haney wrote :
> John French wrote:
>> > 
>> > I believe the problem is name resolution. From the Windows machines, I
>> > can ping any other machine by IP or name. From Ubuntu, I can ping by IP, 
>> > but using a name always brings up, which, I think, is 
>> > OpenDNS. I have tried to fix /etc/resolv.conf, but the Intrepid machine 
>> > always changes it back. The Hardy server lets me change it, but my 
>> > changes don't fix the problem. I can happily make all the IP's fixed or 
>> > DHCP, if so advised. I guess I have messed up my config files trying 
>> > different solutions. Should I re-install ?  And, if so, Intrepid or Hardy ?
>> > 
>> > John
>> > 
> I'd certainly say the problem is name resolution. What I"m curious about 
> is how the Windows machines can ping by name?  Is it able to ping by 
> FQDN?  Or by just hostname? What does /etc/resolv.conf say?

That's fascinating !  I had been pinging from Windows with just the 
hostname (E50, etc.), and that worked. If I use the FQDN, it goes off to

/etc/resolv.conf on my Hardy server reads :


/etc/resolv.conf on my Intrepid desktop reads :



More information about the ubuntu-users mailing list