2 wire DSL

Luke Militello luke at digitalenigma.net
Mon Dec 8 07:16:12 UTC 2008

Leonard Chatagnier wrote:
> --- On Sun, 12/7/08, Luke Militello <luke at digitalenigma.net> wrote:
>> From: Luke Militello <luke at digitalenigma.net>
>> Subject: Re: 2 wire DSL
>> To: "Ubuntu user technical support, not for general discussions" <ubuntu-users at lists.ubuntu.com>
>> I see both interfaces are up and using the same IP address.
>>  Could be a 
>> duplicate route which is confusing the routing table.  Try
>> this...
>>    sudo ifconfig eth0 down
>> Then do...
>>    ifconfig eth0
>> To confirm it is down, then do...
>>    netstat -nr
>> To confirm you only have one default route for
>> via wlan0. 
>>   And finally, try connecting to your 2wire.
> Hi again Luke,
> Had a little prob using the commands. Lost eth0 and connection for a bit and sudo ifconfig up and /etc/network/interfaces restart didn't work.  Slight bit of panic-:))
> But sudo ifdown eth0 and ifup eth0 fixed it. You see, I'm using eth0 now and wired into the router, so lost my connection when I ran your commands.
> Apparently both cards are auto configured, so I removed auto wlan0 from interfaces and reran your commands on wlan0 to see what it says. HTH.
> lchata at ubuntu:/var/log$ sudo ifconfig wlan0 down
> lchata at ubuntu:/var/log$ ifconfig wlan0
> wlan0     Link encap:Ethernet  HWaddr 00:12:17:92:33:D8
>           inet addr:  Bcast:  Mask:
>           BROADCAST MULTICAST  MTU:1500  Metric:1
>           RX packets:31613 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:10394 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:17204325 (16.4 MB)  TX bytes:1981070 (1.8 MB)
> lchata at ubuntu:/var/log$ netstat -nr
> Kernel IP routing table
> Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
>   U         0 0          0 eth0
>     U         0 0          0 eth0
>         UG        0 0          0 eth0
> lchata at ubuntu:/var/log$
> When both card were down after I lost my connection no machine IPs were shown.
> Leonard Chatagnier
> lenc5570 at sbcglobal.net

Did this solve your problem?


Luke J Militello, CCNA
Network Engineer
Technical Operations
Charter Communications
Cisco Certified Network Associate
Michigan Technological University, BS
Computer Network & System Administration

More information about the ubuntu-users mailing list