Can't Navigate My LAN Or Ping

Leonard Chatagnier lenc5570 at
Thu Dec 4 16:43:26 UTC 2008

--- On Thu, 12/4/08, Nils Kassube <kassube at> wrote:

> From: Nils Kassube <kassube at>
> Subject: Re: Can't Navigate My LAN Or Ping
> To: ubuntu-users at
> Date: Thursday, December 4, 2008, 1:33 AM
> Leonard Chatagnier wrote:
> > Using Intrepid 64 bit with Samba, kde4 file sharing
> setup, and static
> > IP's. Intrepid set up DHCP by default and
> initially thought that may me
> > the problem. Have since set up static IP on Intrepid
> but still no joy.
> > Network Manager is still installed and I may need to
> remove it; but
> > don't know. 
> I would uninstall network manager if you want to use static
> addressing. 
> OTOH I would always prefer DHCP, even if the DHCP server is
> set up to 
> always give the same address to individual interfaces.
Thanks for the reply. I was about to purge network manager on my own based on posts I've seen. Have use both DHCP and static with MN installed on earlier versions with no issues. I'm using static as NoOP convinced me that was better but I can be unconvinced if I will fix my sharing issue as I have needs to copy files between PCs. If you have more to add please do. BTW, attyahoo dsl has always provided the same IPs on this side of the router since day one.
> > I can ping each machine(2) from itself but not to the 
> > other. 
> Are both machines on the same subnet? If you are using
> addresses in the 
> 192.168.x.y address range, the default subnet mask of
> limits the subnet to the y part of the addresses, i.e. the
> addresses may 
> only be different at the last number.
Yes, AFAIK. I'm not very network literate, mostly illiterate-:)) But my config is as you list above. Y's are 3 and 2 and subnet mask is as you listed.
> But how are your machines connected? Is there a direct
> cable between the 
> machines or is there a hub / switch / router between the
> machines?
> I have a 2wiew router/modem hardwired to one and a linksys wmp54g wifi on the other and it all worked in hardy but not intrepid.

> > Both Nautilus and Dolphin worked in 8.04 but don't
> connect to 
> > server in 8.10. I have installed nfs on both systems
> and /etc/exports
> > show the shared home folder(rw for each IP, hostname
> on my lan). When I
> > run export sudo exportfs -a, I get output like
> >
> > exportfs: /etc/exports [1]: Neither
> 'subtree_check' or
> > 'no_subtree_check' specified for export
> "ubuntu:/home/lchata". Assuming
> > default behaviour ('no_subtree_check').
> >   NOTE: this default has changed since nfs-utils
> version 1.0.x
> >
> > for each IP and hostname in my lan. 
> This warning is not a real problem. Read "man
> exports" for the meaning of 
> the options but you should at least be able to mount the
> directory. 
> Anyway, first make the machines see each other, i.e. ping
> must work.
Oh boy, I have been trying but don't know what to do. Thanks for the info about exports as I don't know anything about NFS and don't think I was using it before as I never did a setup on it. I've never had an issue pinging between machins before so don't really know what to troubleshoot.

> > 1. Do I even need samba and nfs to share files between
> machines and r/w
> > to each home dir and tempdir in home which are both
> shared folders?
> Depends on what you call "share files". If you
> want to mount directories, 
> I think NFS is what you want. Samba is only useful if you
> want to share 
> files with Windows machines.
I have windows vista on the new machine and keep it up to date occasionally but have no desire to share files on it. I just want the minimal required, simplest setup that allows me to use nautilus/dolphin in kde to copy/move files between machines. And unless NoOP, who helped me get file sharing working for the first time told me how, I never used it before. Sorry, I don't remember about NFS for sure but everything I came across googling was unfamiliar. I got where I am now by following the hits and I know I haven't tried to mount anything yet as the howto was confusing saying I had to mount a new empty dir instead of my home or tempdid set up to share. Hope the info I provided gives you a clue why I can't ping the other machines. If purging network manager doesn't fix it, I'm still lost. Thanks for the input.
Leonard Chatagnier
lenc5570 at

More information about the ubuntu-users mailing list