so, what is your /etc/fstab entry for ntfs partition?

H.S. hs.samix at
Wed Dec 3 03:51:33 UTC 2008

NoOp wrote:
> On 12/02/2008 04:29 PM, H.S. wrote:
>> Hello,
>> I recently noticed that on a dual boot machine running Windows XP and
>> Ubuntu 8.04 if the Window's Desktop folder is opened in nautilus and
>> foo.txt or foo.htm file is double clicked on, nautilus thinks it is an
>> executable (aparently the x bits are set for the files) and wants to run
>> it. It should, however, open the .txt files in a text editor and .htm
>> files in a web browser.
>> I have since changed the /etc/fstab entry for the windows partition to this:
>> UUID=<uid here> /media/WindowsXP-data ntfs
>> defaults,rw,noexec,nosuid,umask=007,gid=46 0       1
>> Actually, I just inserted "rw,noexec,nosuid", specially making the
>> Winodws partition non-executable, in the earlier entry and now nautilus
>> works alright.
>> I am wondering, what do  others use in their /etc/fstab entry to mount
>> an NTFS partition to share its data in Ubuntu.
>> Regards.
> /dev/sdb1 /media/windows  ntfs iocharset=utf8,umask=000    0  0
> works for me.

Not for me though. I tried your example but if I double clicked on a
text file, nautilus tried to run it (or something to that effect)
thinking it was an executable. I added the "noexec" option to mount
options and remounted the partition then the file association in
nautilus worked okay.

It appears that without the "noexec" option all files in ntfs are seen
as having their x bit set.

More information about the ubuntu-users mailing list