newbie's question on file permission

POWERS, ZACK zpowers at
Fri Aug 1 19:17:32 UTC 2008

Both read and write permissions are supported with NTFS in Linux
through the FUSE module. In Ubuntu this support can be installed by
using Synaptic to install the ntfs-3g package. Since 7.04 Feisty Fawn,
ntfs-3g has been the default for mounting NTFS partitions. Once you
mount the volume with ntfs-3g then you may use POSIX styled file
permissions on all files.
-----Original Message-----
From: ubuntu-users-bounces at on behalf of Zhengguo Xu
Sent: Fri 8/1/2008 3:09 PM
To: Ubuntu user technical support,not for general discussions
Subject: Re: newbie's question on file permission
many thanks!  all of you. how can I change the permission for whole

2008/8/1 Zhengguo Xu <tworiversfolk at>

> Thanks a lot, Zack!! it indeed is FAT32 disk. I do need to connect
> disk to windows from time to time, but I had the impression that
NTFs is not
> best support by Linx. or am I completely wrong about it? writing to
> disk in linux is now perfectly normal?
> 2008/8/1 POWERS, ZACK <zpowers at>
>> Hi,
>> The reason permissions don't change on your USB stick is because
>> USB disk is formatted in a filesystem that does not support POSIX
>> style file permissions. If its FAT16 or FAT32, which it is most
>> is, it doesn't support any type of file permissions. To solve this
>> issues you will have to reformat your USB disk to a POSIX compliant
>> filesystem (NTFS would be the best choice for compatibility with
>> Windows).
>> -----Original Message-----
>> From: ubuntu-users-bounces at on behalf of Zhengguo
>> Sent: Fri 8/1/2008 2:37 PM
>> To: Ubuntu User
>> Subject: newbie's question on file permission
>> Greeting all!
>> Recently I encounted a strange problem (or it maybe very obvious
>> you
>> guys) while copying files and I'd like to ask a question on file
>> permission
>> in linux.
>> I have a file, lets say 'biology.ppt' and it has permission as
>> and i
>> am the owner and it belongs to group 'root'
>> -rwx------
>> i want to change it to group, say, 'test', and give permissions to
>> everyone
>> to read and write and execute, what's wrong when I run the
>> command?
>> sudo chgrp test biology.ppt
>> sudo chmod 777 biology.ppt
>> nothing happened when i run these commands and i tried them with
>> without
>> sudo. the file still has the permission -rwx------ and root is
>> the
>> group.
>> if it matters, the file is on a usb disk mounted in /media
>> i also tried to create some file in my home directory and i can
>> it as
>> i want with the same command.
>> any help would be greatly appreciated.
>> --
>> ubuntu-users mailing list
>> ubuntu-users at
>> Modify settings or unsubscribe at:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: winmail.dat
Type: application/ms-tnef
Size: 4353 bytes
Desc: not available
URL: <>

More information about the ubuntu-users mailing list