Fwd: USB Drive sometimes auto mounts as read-only (resolved)

Anna EdwARds ash.1574 at hotmail.com
Sat Apr 26 23:15:47 BST 2008


You could put an ext2 driver on windows from fs-driver.org

_____________________________
Sent from my phone using flurry - Get free mobile email and news at: http://www.flurry.com

--- Original Message ---
Date: Sat Apr 26 14:30:01 PDT 2008
From: Niels Andersen 
To: "Ubuntu user technical support,
	not for general discussions" 
Subject: Fwd: USB Drive sometimes auto mounts as read-only (resolved)
---

---------- Forwarded message ----------
|| My USB Drive sometimes auto mounts as a read-only file system on Ubuntu 7.10 i386 desktop.
||  This does not happen frequently, but when it does, it means I can't update any files on the drive.
||  How do I switch it to a read-write file system?  Is there something I can do to keep it
|| from being mounted as read-only?

|| I have tried unmounting it and inserting it into another USB port, with the same results.
||  I am going to reboot my desktop  to see if I can |  resolve this issue. If that fails, I
|| intend to copy all the files off the USB drive, format it (as FAT32), and then restore the files.

|The reboot did not resolve the issue.  Next, I will try copying the files from the USB drive,
|reformat it, and then put the files back on.

The reformat worked. Looks like the USB drive became corrupted...again!

Before I reformatted the drive I copied all the files into a temporary directory,
"Niels USB Drive", on my desktop.

Since the drive was corrupted, the drag and drop would freeze, soI had to copy
one sub-directory at a time.  The drag and drops still froze, and the copy messages
boxes never closed, so I had to check that the files were indeed copied
to the temporary directory and could be opened.

I had to log out a couple of times to clear the copy messages, and then continue
copying directories to the temporary directory.

Once the files were copied, I used fdisk -l to determine the drive name (/dev/sdc1).
Then used the Gnome Partition Editor, Gparted (previously installed), to unmount
and format the USB drive as FAT32.  The USB drive needs to be readable by a Windows XP machine, so FAT32 is mandatory.

Gparted is scary, because it is possible to inadvertently format the hard drive
instead of the USB drive (I have not, and never intend to confirm this statement).

I like my drives to have names so after the drive had been formatted I used mlabel to
label the drive:

$ sudo mlabel -i /dev/sdc1 ::Niels

The new label doesn't show up, so I unmounted and re-mounted the drive to confirm that ubuntu could see the new label.

Lastly I copied the files back.

-- 
Niels Andersen
Guelph, Ontario, Canada

--
Computers are time pits.  You sit down to do a few minutes work and finish a couple of hours later!  Arrrggghh...

-- 
ubuntu-users mailing list
ubuntu-users at lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


_________________________________________________________________
In a rush? Get real-time answers with Windows Live Messenger.
http://www.windowslive.com/messenger/overview.html?ocid=TXT_TAGLM_WL_Refresh_realtime_042008
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-users/attachments/20080426/7b6d0dbb/attachment-0001.htm 


More information about the ubuntu-users mailing list