Pinnacle PCTV HD Pro USB does not work under Ubuntu 8.04.

Bo Peng ben.bob at gmail.com
Tue Apr 29 16:20:21 BST 2008


Dear all,

I installed a fresh copy of Ubuntu 8.04 and tried to install a
'Pinnacle PCTV HD Pro USB stick'. I read and followed all the
tutorials I could find but this device simply did not work (it works
under windows). Here is what I have done:

1. I found that I did not have to install the em28xx driver because
'modprobe em28xx' worked out of box. What a pleasant surprise.

2. lsusb lists the device fine:

Bus 007 Device 004: ID 2304:0227 Pinnacle Systems, Inc. [hex]

3. dmesg | grep usb yields

[ 444.584352] usbcore: registered new interface driver em28xx

However, there is no detailed information about this device, as shown
on some tutorials. I also notice that there is no /dev/video0. As a
result, kaffeine said 'could not find any DVB-device', me-tv said that
'no tuner device'.

I suspected that the system does not have the correct firmware so I
downloaded and unpacked the firmware to /lib/firmware, rebooted the
system, but got the same result. I suspected the em28xx driver was not
up to date so I downloaded and installed the driver again, but the
problem persists. Can anyone help?

Many thanks in advance.
Bo




More information about the ubuntu-users mailing list