Unable to remove directory

Markus Schönhaber ubuntu-users at list-post.mks-mail.de
Sat Apr 12 19:08:08 BST 2008


JosephK wrote:

> On 18:57 Sat 12 Apr     , Markus Schönhaber wrote:

>> Did you try
>> rmdir /mnt/music/mp3s/Bj*
>> ?
> 
> Tried that and other combinations too. mc which is my file manager of
> choice would not delete it so I tried the Gnome default graphical file
> manager. The folder shows up but as soon as you click on it, right or
> left button, it disappears and then reappears when you refresh the
> window.
> 
> Cannot even delete the containing directory. This is on a smb shared
> folder on an xfs server. All files are backed up so I think I'll just
> delete the share and reinstall it.

One thing that might work is deleting the dir without using it's name
directly but by using it's inode number. I. e. do something like
ls -i /mnt/music/mp3s/Bj*
which should tell you the inode number of the dir. And then
find /mnt/music/mp3s -inum <inode number shown by ls -i> -exec rmdir {} \;

Regards
  mks




More information about the ubuntu-users mailing list