php module for apache not working

Darren Mansell darren.mansell at
Tue Sep 25 09:33:37 UTC 2007

On Tue, 2007-09-25 at 14:57 +0530, H.S.Rai wrote:
> On 9/24/07, H. S. Rai <hardeep.rai at> wrote:
> > On 9/24/07, Nik <nik at> wrote:
> >
> > No. There is only Apache2.
> Thanks for all who tried to solve my problem.
> Please treat yourself expert and myself as newbie :-(
> There was no apache, but there was apache-perl, which made me think
> that apache (1) is not there. Noe I have removed it. The problem of
> apache2 restart has gone.
> Now, on my system, I have apache2, php5-mysql, libapache2-mod-php5,
> and mysql-server, (I guess things for LAMP), bu still php file tries
> to download. Where I can look now?
> I could not run tasksel,as I have use Internet through proxy, and I
> don't know who too use aptitude (tasksel), through proxy, so that I
> can try to install LAMP using tasksel.
> -- 
> H.S.Rai

I just tried it and it did ask to download a phtml file instead of
parsing PHP.

I run sudo a2enmod php5, it said it was already enabled so I restarted
apache2 and it worked.

Something to try?

More information about the ubuntu-users mailing list