LIRC and Dapper

Michael frandsen mf1910 at
Sat Sep 15 15:22:35 UTC 2007

Brian McKee skrev:
> Hi All
> 	I have an MSI TV at nywhere video capture card that comes with a remote.
> The card itself was 'plug n play'.  tvtime worked as soon as I installed
> and rebooted.  The problem is I cannot figure out how to get that remote
> working.   As near as I can tell it's not on there list so I have to run
> 'irrecord' to create a template for it.  But I can't even get that far.
> If I run sudo /etc/init.d/lircd start I get 
> I gather the next step is running  irrecord
> Running that I get 
> 	irrecord: could not init hardware
> I don't have a /dev/lirc but I do have a /dev/lircd
> I changed it's ownership to and did a chmod 666 on it.  
> No change.  I have no idea what to do next...
> I actually posted this on the LIRC list several days ago but got no
> response, which was pretty disheartening...
> Pointers appreciated.
lirc have different drivers for different ir receiver harware. you need 
to load the correct module unless it have it loaded automaticly. Like I 
have imon vfd with buildin ir receiver so I have to modprobe lirc_imon. 
My capture card have an i2c type so lirc_i2c instead. The dev/lircd will 
be there even the correct module is not loaded on my system I got 
/dev/lirc0 too.

in my /etc/modules I have following lines unsure if the lirc_dev is 

Hope it helps

More information about the ubuntu-users mailing list