Gutsy installer, GParted don't see my existing partitions

Ari Torhamo ari.torhamo at
Fri Sep 7 21:59:29 UTC 2007


I met a partitioning problem when I tried to install Gutsy (Daily, Sept.
6). The partitioner doesn't see any of my current partitions and says
the entire disk space is non allocated. The partitions work normally,
and only GParted (both the installed version in Feisty and the one on
Gutsy Live CD) and the istaller partitioner seem to have a problem with
them. Device Manager and fdisk report the partitions correctly (as far
as I can tell). 

This is what fdisk says:

omitting empty partition (5)

Levy /dev/sda: 250.0 Gt, 250059350016 tavua
255 päätä, 63 sektoria/ura, 30401 sylinteriä
Yksiköt = 16065 * 512 = 8225280 -tavuiset sylinterit

    Laite Käynn     Alku          Loppu    Lohkot   Id  Järjestelmä
/dev/sda1   *           1        2805    22531131    7  HPFS/NTFS
/dev/sda2            2806        4629    14651280   83  Linux
/dev/sda3            4630       30401   207013590    5  Laajennettu
/dev/sda4            7059       30401   187502647+  83  Linux
/dev/sda5            4630        4872     1951834+  82  Linux / Solaris

I run fsck too from the installer CD and the result was "clean" for both
ext3 partitions. I'm not sure if I did it right though, because the
whole checking process took only a couple of seconds. If I remember
right, I did just "sudo fsck /dev/sda2(4)".

Does anyone have any suggestions on what might be wrong here. Is the
problem with the file system or the partitioner? Can it be corrected? I
tried to search for the answer, but I found it hard to find a search
string that would separate my problem from the numerous general
instructions for partitioning a hard disk.

I already added my case to an existing bug report (which doesn't seem to
have much activity around it):

Thanks :-)

Ari Torhamo

More information about the ubuntu-users mailing list