Mutt Basic

Leonard Chatagnier lenc5570 at
Wed Sep 5 04:53:08 UTC 2007

Peter Garrett wrote:
> On Tue, 04 Sep 2007 02:12:41 -0500
> Leonard Chatagnier <lenc5570 at> wrote:
>> Peter Garrett wrote:
> [snips]
>>> 	You can even do this in one line something like
>>> mutt -f imaps://arthur.dent:t0w3Lm1ss!
>>>                     ^^^^      ^^^^
>>>                    username:password 
>>>         The -f tells mutt it is looking for a file. It doesn't care if 
>>>         the file is local or not. this way is a bit clumsy, and we 
>>>         probably want to use TLS or something similar rather than a 
>>>         plain text login. ~/.muttrc allows us to do this.
>> Ok, tried this with:
>> mutt -f 
>> imaps://
>> output:Could not connect to (Interrupted system 
>> call).
>> and with:
>>   mutt -f 
>> maps:// to get 
>> rid of pop.
>> output:Could not find the host ""
>> Also tried with imap ipo pop with this output:
>> Could not find the host ""
>> Either yahoo was no imap server or I'm missing something.
>> Also didn't work with mail ipo imap, imaps, or pop.
>> Perhaps you will clarify or am I missing some prerequisite.
> I have no idea whether Yahoo support imap, so I don't think I can help
> there. It is possible to view pop3 with a line like the ones above - for
> instance here
> mutt -f pop://
> downloads the headers and displays them fine.
> Perhaps you are prepending "pop" to the server name - pop is a protocol, so
> it goes at the beginning:
> pop://
> imap://
> imaps://
> and so on. On the other hand, I notice that your server name specifies
> pop, so perhaps this server just doesn't understand imap.
> [ snips ]
>>>      	I know this ruins the mystique, but actually it is rather 
>>>      	simple. ;-) I get the impression a lot of people who write 
>>>      	about this stuff are deliberately complicating it.
>> Not simple for me. Welcome your tutorial.  Looking forward to more.
> Heh - I guess it's easy to say something is simple *after* getting it to
> work ;-)  What I meant was that much of the "explanation" found on the web
> about mail unintentionally makes this stuff more difficult than it
> actually is, by wrapping it in technical language.
>>>      	Hope this is some use conceptually. It may not be technically 
>>>      	pure but I think it helps to explain things ...
>> Thanks very much, Peter, for this. Best explanation of how mail and mutt 
>> works, I've seen. I for one want to see your more-or-less generic config 
>> on the model you are currently using. You are appreciated.
> OK - well I have attached two files - muttrc-basic   and msmtprc-basic .
> They are more or less what I am currently using ( I've added a few bits
> since I started, but these work )
> I found that having the  my_hdr From ...worked where  set *envelope*
> etc. did not - commented out in the muttrc 
> As you will see, the syntax of msmtprc is very straightforward . 
> Substitute as relevant - these are my optus settings with my user name.
> "xxxxxx" is probably not a good password choice *grin* .
> Obviously you use them as ~/.muttrc  and ~/.msmtprc respectively .
> You don't really need to include the password line - mutt prompts for one
> on startup as it connects. In fact having the password in the muttrc could
> be a security issue. 
> Important point: both .muttrc and .msmtprc have permissions of 600 
> (readable and writable only for your user)
> Peter
Peter, thanks very much for the *rc files.  Think I'm good for now but 
it will take me awhile before I get everything in place and proofed out.
I'm a little surprised at how much progress I've make in so short a time 
thanks to you and others and a little bit more effort on my part.  As 
mentioned in an earlier post, I have everything going except sending and 
need to work on postfix for that and a lot of cleanup and optimization 
in all the rc files to do yet.  Thanks to you and others who contributed 
to this effort, I have mutt just about totally functional.  At one 
point, I thought that I'd never get mutt to work and wouldn't have save 
for the list's help.  As soon as I have everything functioning, I'll 
post on what I've done and maybe it will help other noobies like me.
But not as much as your tutorial, please continue.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lenc5570.vcf
Type: text/x-vcard
Size: 116 bytes
Desc: not available
URL: <>

More information about the ubuntu-users mailing list