screen flickers after switching back from terminal to gdm

NoOp glgxg at sbcglobal.net
Thu Nov 29 17:58:38 GMT 2007


On 11/28/2007 06:13 AM, Bram Kuijper wrote:

> 
> PS: my xorg error log is in pastebin:
> http://pastebin.com/m246e1a5d
> 
> PS2: my graphical card is a Intel 82Q963/Q965 Integrated Graphics 
> Controller. The graphics driver I use is the i810 driver.
> 
> 

You might want to go through the log and pay attention to the error
messages. For instance:

# (II) I810(0): Broken BIOSes cause the system to hang here.
#               If you encounter this problem please add
#                  Option "DisplayInfo" "FALSE"
#               to the Device section of your XF86Config file.

My guess is that the monitor is being set to a higher freq range than it
can handle when it returns from tty. My recommendation would be to force
it to 60hz and see if that fixes the problem.

Your monitor appears to support:

Timing characteristics
  VESA GTF support............ Not supported
  Horizontal scan range....... 24-83kHz
  Vertical scan range......... 55-76Hz
  Video bandwidth............. 140MHz
  Extension blocks............ n/a
  Timing recommendation #1.... 1280x1024 at 60Hz
      Modeline................ "1280x1024" 108.000 1280 1328 1440 1688
1024 1025 1028 1066 +hsync +vsync

Standard timings supported
   640 x  480 at  60Hz - IBM VGA
   640 x  480 at  67Hz - Mac II
   640 x  480 at  72Hz - VESA
   640 x  480 at  75Hz - VESA
   720 x  400 at  70Hz - IBM VGA
   800 x  600 at  56Hz - VESA
   800 x  600 at  60Hz - VESA
   800 x  600 at  72Hz - VESA
   800 x  600 at  75Hz - VESA
   832 x  624 at  75Hz - Mac II
  1024 x  768 at  60Hz - VESA
  1024 x  768 at  70Hz - VESA
  1024 x  768 at  75Hz - VESA
  1152 x  864 at  75Hz - VESA
  1280 x 1024 at  60Hz - Iiyama
  1280 x 1024 at  60Hz - VESA
  1280 x 1024 at  75Hz - VESA

According to this:
http://www.911cd.net/forums//lofiversion/index.php?t15749.html
[scroll down to
RvdH
Feb 1 2006, 04:55 PM
cdob, thanks, finally a answer that answers my question]

However, I was installing a Gutsy for my son this past weekend & he has
a Samsung LCD monitor. I was playing around with the freq ranges and
encountered exactly what your are experiencing: grey screen flickering,
etc., etc. I set the timings to 60hz and all worked well after that.





More information about the ubuntu-users mailing list