7.04: X11 remote display problem

bill purvis bil at beeb.net
Wed Nov 21 14:55:19 UTC 2007

On Wednesday 21 November 2007, Smoot Carl-Mitchell wrote:
> On Wed, 2007-11-21 at 12:18 +0000, bill purvis wrote:
> > I'm still having no joy with getting anything to open a remote X11
> > window on my laptop since I changed to Ubuntu from Mandrake.
> >
> > I'm using ssh to log in to my server (and yes I've tried using ssh -X
> > but that makes no difference). Once I'm logged in I try to start an
> > emacs window on the laptop:
> >
> > server$ echo $DISPLAY
> > felix:0.0
> > server$ emacs &
> > server$ emacs: Cannot connect to X server felix:0.0.
> > Check the DISPLAY environment variable or use `-d'.
> > Also use the `xhost' program to verify that it is set to permit
> > connections from your machine.
> Turn on X11 port forwarding on your ssh client and server. The X session
> will be port forwarded over the SSH connection which is a more secure
> way to run X remotely. The relevant configuration files
> are /etc/ssh/ssh_config and /etc/ssh/sshd_config.
> --
unless I'm mis-reading it this is turned on:

/etc/ssh/ssh_config (on felix)

#   ForwardX11 no

and in any case, I tried it with -X option which is supposed to override
that and it still don't work.

Oh, and I've got 

	X11Forwarding yes

in /etc/ssh/sshd_config on both machines.

| Bill Purvis, Amateur Mathematician    |
|  email: bil at beeb.net                  |
|  http://bil.members.beeb.net          |

More information about the ubuntu-users mailing list