x server failed to start, nVidia

Chris Mohler cr33dog at gmail.com
Wed Nov 7 00:03:45 UTC 2007

On Nov 6, 2007 1:03 PM, James Black <text4909 at gmail.com> wrote:
> Hello all, i am running ubuntu on a dell laptop. i went 2 restricted
> drivers to install the nvidia and after reboot i get an error telling
> me `failed to start x server(your GUI)...`  so far edited the xconfig
> frm vesa 2 vga. any help appreciated

AFAIK, three drivers operate a Nvidia card under *nix:
nv  - the nouveau driver - the open-source community Nvidia driver
vesa - vesa-mode driver
nvidia - the proprietary Nvidia driver

I use 'vesa' for failsafe - if nothing else works and I need to do
something gui.
I've had mixed results with 'nv' - sometimes it works, sometimes not.
3D has never worked that well for me, but they're working on making it
On this vostro 1500, I'm using the 'nvidia' driver - works
beautifully.  Although after installing the nvidia driver, I did:
sudo dpkg reconfigure xserver-xorg
and rebooted.
Back up your xorg.conf :)

I've never tried using 'vga' with a nvidia card - not sure if that
will even work...


More information about the ubuntu-users mailing list