problem with programs

Haneef Bashir darkfena313 at
Fri Nov 2 10:28:30 UTC 2007

thanks Leonard i think the advice you gave helped but now i have t an
issue accesing any of the paccage mannager
GUI displays this at the end after innitiatiing  upgrade:
Fetched 2458kB in 1m40s (24.5kB/s)
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource
temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is
another process using it?
E: Couldn't rebuild package cache
 ow  do i unlock it?

On 10/31/07, Leonard Chatagnier <lenc5570 at> wrote:
> --- Haneef Bashir <darkfena313 at> wrote:
> > i tried the comman and this is what happened:
> >
> I should mention that user list protocol prefers you
> bottom post instead of top post.  Some will get highly
> perturbed over top posting. FWIW.
> It looks like aptitude is trying very hard to fix the
> dependencies/broken emacs21 package but not quite
> getting there.  Remember I'm no expert but if I lead
> you astray someone on the list will jump in and
> correct me.  That said you can try other things:
> Try "sudo aptitude -f install" again.
> Try "sudo aptitude" to enter the aptitude GUI. Type
> "b" to see the list of broken packages and check the
> dependencies listing. Select the broken package(s) for
> installation. If doesn't work, try installing the ones
> listed that are not installed(depends). The GUI of
> aptitude is powerful but hard to use if not familiar
> with it.  Look closely at the listed dependencies and
> mark all for installation.  I just used the aptitude
> GUI to repair broken package/dependencies resulting
> from installing mailx and it worked holding back
> mplayer but an aptitude update followed by aptitude
> dist-upgrade resulted in upgrading mplayer to where it
> was before installing mailx. When you first open the
> aptitude GUI, there will be some data at the bottom of
> the screen in red highlighting that will give you an
> option to accept fixes. Select the "accept"(note there
> is coded key to type) and review the list of actions
> it will perform.  You can reveiw the actions and
> change them as desired then under the action drop down
> menu select the first item "install/removepackages g"
> or just type "g" from the keybord. This will implement
> the actions accepted.  Follow this, when you get back
> to the CLI with "sudo aptitude update" then "sudo
> aptitude upgrade" then "sudo aptitude dist- upgrade
> and barring
> any more errors you should be ok and can install any
> more programs wanted. Remember awithout the quotes on
> the commands. I wrote this as if you have no
> experience with the aptitude GUI and probably poorly
> at that. If I'm correct in that assumption you should
> read the manual or at least open the GUI and play
> around with it. No action will take place until you
> type "g" or select same from action drop down menu.
> You can also try installing "emacs21" seperately.
> You can do "aptitude show <package name> that will
> show all the dependencies/conflicts to get more ideas
> of what to do.
> Try "sudo dpkg-reconfigure <package name> which may
> help.
> You can try the -f switch for aptitude install but
> that cause other trouble and is not normally
> recommended but I have used it(like "sudo aptitude -f
> install emacs21)
> Closely read the error output of any command you try
> as it may clue you to what's wrong.
> Good luck, try it out and report back(with error
> output) if still having problems and someone will help
> you out.  If my suggestions don't help, I'm out of
> ideas and someone more experienced will need to chime
> in.
> Good luck,
> Leonard Chatagnier
> lenc5570 at
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:

More information about the ubuntu-users mailing list