Strange USB Scaner Problem

NoOp glgxg at
Tue May 22 15:36:08 UTC 2007

On 05/22/2007 12:47 AM, Jack Bowling wrote:
> On Mon, May 21, 2007 at 03:31:38PM -0700, Mitch Contla wrote:
>> On 5/19/07, Amichai Rotman <amichai at> wrote:
>> >
>> >Hi all,
>> >
>> >I have Canon LiDE 20 USB scanner connected to my 7.04 box.
>> >
>> >It worked fine with Kooka and XSane on 6.10...
>> >
>> >Problem: I can see the scanner in lsusb and when I fire up the apps it
>> >asks me which device I want to use (I also have a BT878 TV capture card) 
>> >but
>> >when I hit the preview or scan buttons (in the app, not hardware) it runs
>> >the percentage  till completion but the motor doesn't move and when it
>> >completes it comes up as all black...
>> >
>> >Is it a Feisty problem or did my scanner just died at a perfect timing?
>> >
>> >How do I check it?
>> >
>> ><--snip->>
>> >
>> Here's a couple things that have helped me when I have had sane problems:
>> 1. Does sane-find-scanner recognize your scanner properly?
>> 2. What are permissions on /dev/bus/usb/{your_usb_addr? Mine are 664.
>> 3. Have you tried rm -fr ~/.sane (use at your own risk... has solved many
>> sane problems for me)?
> I think this bug goes pretty deep into libusb/udev territory. My Epson
> Perfection 2400 works fine on my USB v1.1 bus but errors out on my USB
> v2 bus. Weird. Seems to be a timing issue at least.
> Jack

Interestingly enough, this problem is listed in both the Edgy and Feisty
pages for see:


and for Edgy:


 Workaround for random device disconnections

Random disconnection is a kernel bug that is not fixed yet. Some users
report randomly disconnecting USB devices, especially external hard
drives. One solution is to start the system with the option "irqpoll" in
grub, but this doesn't work for everybody, and is believed to make the
whole system slower. The other solution is to disable USB 2.0. This will
result in way slower read/write, but the connection remains stable.

To disable USB 2.0, type this in the terminal:

sudo modprobe -r ehci_hcd

Test if the copy/write process is stable, and if you want to disable USB
2.0 upon boot, type:

sudo sh -c 'echo blacklist ehci_hcd > /etc/modprobe.d/blacklist-ehci'
sudo update-initramfs -u -k `uname -r`


Perhaps the reason that I am not having problems with the scanner on my
Canon MP750 is that I have no USB 2 ports - all of my ports are USB 1.1.

More information about the ubuntu-users mailing list