on startup scripts

James Takac p3nndrag0n at gmail.com
Sun May 13 10:59:50 UTC 2007

Hi Nils

Prob solved. Found it's a bug that affects some systems and not others. The 
fix is to set the owner of .config/autostart to the user rather than root on 
the systems affected. From then on System->Preferences->Sessions-Startup 
programs will then work as expected.

On Sunday 13 May 2007 20:25:27 Nils Kassube wrote:
> James Takac wrote:
> > Tried that so far in the scripts, in my case using .gnomerc in the user
> > directory to house the script. Alas it sleeps then continues to load
> > gnome
> >
> > >from what I can tell. Currently looking into placing a script inside
> > > the
> >
> > init.d directory but need to work how to get it to execute.
> Things in /etc/init.d are meant to be started at boot time or when the
> runlevel changes. Therefore it is probably not the right place for your
> command which you want to start after login. Therefore, if the other
> suggestions in this thread don't help you, you could try the script of my
> previous post in this modified version:
> #!/bin/sh
> /bin/sleep 20 && /path/to/your/command &
> exit 0
> Nils

More information about the ubuntu-users mailing list