Feisty Install Dies at Grub (94% complete) w/RAID0 (dmraid)

Paul S paulatgm at gmail.com
Tue May 8 01:52:34 UTC 2007

Oscar Usifer said the following on 05/07/2007 08:02 PM:
> Folks,
> I ran the install for ubuntu-7.04-desktop-amd64 on a RAID0 configured 
> with dmraid. The installer made it to 94%, where it attempted to setup 
> grub, then died. How can I discover what that last 6% of the install does?

I had a similar problem happen to me on i386 with no raid .. it died 
when it tried to install grub.  But in my case, I knew the problem, 
because I had hit the "advanced" button just before proceeding with the 
install.  The advanced popup allows you to specify where you want grub 
installed.  I had put an invalid device .. used (hd8) instead of 
/dev/sda8.  As soon as it crashed, I realized I had used the wrong 
syntax.  When I restarted, I found out that it killed my vista 
partition, and I had to reload vista.  In addition, I reinstalled 
kubuntu, but used the correct /dev/sda8 for the grub location.

If you did not specify a special grub install location with the 
"advanced" button just before proceeding with the install, then the 
default location must not have been possible for your configuration. 
So, try it again, and this time select a valid grub install location. 
I'm not at all familiar with raid, so can't suggest what is valid for 
grub on raid arrays.


More information about the ubuntu-users mailing list