Wired network-connection problems solved ... but why?

Stephen R Laniel steve at laniels.org
Thu May 3 15:21:35 UTC 2007


On Thu, May 03, 2007 at 10:15:50AM -0500, Ben Sandee wrote:
> Just add 'e1000' to /etc/modules.  I don't know why e1000 isn't autoloaded and
> it might be appropriate for you to address that by filing a bug, but to get you
> going this should suffice.

Sure. I mean, now that I've solved it I know how to keep it
from happening again. But the reason it took me so long to
figure this out is that I just expect Ubuntu to get the
low-level things -- like making a very standard NIC function
correctly -- right. I guess I thought we were past the point
where this sort of issue would crop up, but maybe that's
naive of me.

Googling for bcm5751m+e1000 yields
http://www.thinkwiki.org/wiki/Ethernet_Controllers
which suggests that problems with the tg3 driver may be the
issue. If anyone has further details, let me know.

If the tg3 is the problem, then the workaround will probably
involve auto-removing tg3 as well as auto-loading e1000,
yes?

-- 
Stephen R. Laniel
steve at laniels.org
Cell: +(617) 308-5571
http://laniels.org/
PGP key: http://laniels.org/slaniel.key
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20070503/759b5197/attachment.pgp>


More information about the ubuntu-users mailing list