Removing a Broken Package (courier-authdaemon)

Soo-Hyun Choi s.choi at hackers.org.uk
Fri Mar 2 03:02:49 GMT 2007


Thanks Wei-Yee, I think it's a bug, too.

I was trying to upgrade from Dapper to Edgy by simply changing
/etc/apt/sources.list file. And I encountered this problem. I can now
reckon that there are many people who had same situation like me.



On 3/2/07, Wei-Yee Chan <chanweiyee at gmail.com> wrote:
> I think it's a bug.
>
> https://launchpad.net/ubuntu/+source/courier-authlib/+bug/64615
>
> Regards,
>
> Wei-Yee Chan
> http://chanweiyee.blogspot.com
>
>
> Soo-Hyun Choi wrote:
> > Hi,
> >
> > I am getting the following error message when I force to remove a
> > broken package (courier-authdaemon).
> >
> >
> > soohyunc at quokka:/var/cache/apt/archives $ sudo dpkg -r
> > --force-remove-reinstreq courier-authdaemon
> > dpkg - warning, overriding problem because --force enabled:
> >  Package is in a very bad inconsistent state - you should
> >  reinstall it before attempting a removal.
> > (Reading database ... 124565 files and directories currently installed.)
> > Removing courier-authdaemon ...
> >  * Stopping Courier authdaemon...
> >          exec: 31: /usr/sbin/courierlogger: not found
> >                                                                          [fail]
> > invoke-rc.d: initscript courier-authdaemon, action "stop" failed.
> > dpkg: error processing courier-authdaemon (--remove):
> >  subprocess pre-removal script returned error exit status 1
> >  * Starting Courier authdaemon...
> >          exec: 31: /usr/sbin/courierlogger: not found
> >                                                                          [fail]
> > invoke-rc.d: initscript courier-authdaemon, action "start" failed.
> > dpkg: error while cleaning up:
> >  subprocess post-installation script returned error exit status 1
> > Errors were encountered while processing:
> >  courier-authdaemon
> > soohyunc at quokka:/var/cache/apt/archives $
> >
> >
> >
> >
> > It basically complains that it cannot fine /usr/bin/courierlogger, but
> > I don't know how to remove this broken package. Would you please give
> > me a clue how I can remove this package? Because of this reason, I
> > cannot do "apt-get dist-upgrade" and I cannot install any other
> > packages.
> >
> > Your help would be much appreciated.
> > Thanks,
> >
> >
>
>
>
> --
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
>
>
>




More information about the ubuntu-users mailing list