SOLVED: Re: Synaptic is stuck - removing partially installed package? / VirtualBox

Chanchao custom at
Wed Jan 31 01:47:19 UTC 2007

On Tue, 2007-01-30 at 03:37 +0100, Florian Diesch wrote:

> > Result is that I can't use Synaptic or apt-get for anything anymore, not
> > even removing that package!!
> >
> > This is what happens:
> >
> > $ sudo apt-get remove virtualbox
> > Reading package lists... Done
> > Building dependency tree       
> > Reading state information... Done
> > E: The package virtualbox needs to be reinstalled, but I can't find an
> > archive for it.

> I guess /etc/init.d/virtualbox fails to unload a kernel module. If you
> know a little bit about shell programming you may fix it. A quick&dirty
> solution is to just insert a line
>  exit 0
> right after the line starting with #!

Thanks!!!  I think what I got happens a lot, and I just saw this
solution is now on the FAQ at the VirtualBox site. 

After getting it uninstalled, I solved the problem by changing the
kernel from linux-386 to linux-generic; apparently the one VirtualBox

After that: It runs GREAT..  Very comfortable to run Windows in a Window
(or full screen) in Ubuntu now!!


More information about the ubuntu-users mailing list