list file for package missing final newline

Fernan Aguero fernan.aguero at
Thu Jan 11 22:13:18 UTC 2007


I'm having a problem since yesterday where I can't install
any package on my Ubuntu Edgy.

The error message is always something like:

E: /var/cache/apt/archives/libid3-3.8.3c2a_3.8.3-5_i386.deb:
files list file for package `libgtk1.2' is missing final

This happened with both the latest security updates
(linux-restricted-modules-common), and with other packages I
tried to install.

I tried to reinstall libgtk1.2, given that it seems to be
the root of the problem, but:

[fernan at sigma:/var/cache/apt] sudo apt-get --reinstall install libgtk1.2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 6 not upgraded.
Need to get 837kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 edgy/main libgtk1.2 1.2.10-18 [837kB]
Fetched 837kB in 11s (75.1kB/s)                                                
(Reading database ... dpkg: error processing /var/cache/apt/archives/libgtk1.2_1.2.10-18_i386.deb (--unpack):
 files list file for package `libgtk1.2' is missing final newline

I read elsewhere that I could edit the plist in the package
to add this missing newline, but I'm a new Debian/Ubuntu
user, and I don't know my way about unpacking, editing, and
either installing from the unpacked package or repackaging
and installing from there ... the .deb file it's a binary
file (can't edit with vim), but the less(1) included in
ubuntu seems to be smart (or is a wrapper) and shows me the
content of the file ... is this a .tgz or similar kind of
archive in a different disguise?

Are others getting this problem? (I mean, is this a problem
with the package, that should be fixed by the packager?)

Thanks for any tip,


More information about the ubuntu-users mailing list