Cannot connect to my wireless AP

James Gray james at
Fri Jan 5 04:26:10 UTC 2007

Feral wrote:
> Hey there.
> I'm having some major issues connecting to my wireless AP (D-Link 
> G604T), with my Belkin F5D7050, using the RT73 drivers.

Just so that I'm not reading this wrong, your PC/Lappy has a SINGLE 
wireless interface (the Belkin F5D7050) and you have a single access 
point (the D-Link).

Based on this interpretation...

> I have turned off WEP/WPA, manually set the channel to 6, and made sure 
> the ESSID is the same.
> When I run "sudo iwlist wlan0 scan":
> wlan0     Scan completed :
>               Cell 01 - Address: 00:17:9A:12:03:7A
>                     ESSID:"DLINK"
>                     Mode:Master

"Mode Master" is ONLY used to turn your wireless card into an access 
point.  You probably want to use "Managed" mode which is used when you 
have an access point.

Read "man iwconfig" for the details about the modes.

> When I run "sudo iwconfig":
> wmaster0  IEEE 802.11g  Frequency:2.437 GHz 
>                    RTS thr:off   Fragment thr=2346 B  
> wlan0        IEEE 802.11g  ESSID:"DLINK" 
>                   Mode:Managed  Frequency:2.437 GHz  Access Point: 
> Not-Associated  
>                   RTS thr:off   Fragment thr=2346 B  
>                   Encryption key:off
> I cannot, for the life of me, seem to get my wireless card to connect to 
> my AP, even though I can clearly see it if I scan for it.
> Does anyone have any idea what might be up? Bear in mind I've been using 
> linux a grand total of two days so far - so I'm not very good at doing 
> this kind of thing.

The ONLY things you should need in your /etc/network/interfaces file (to 
connect to a completely open, and unencrypted access point):

(WARING! DO *NOT* remove the loopback entry "lo", just add the following 

--- /etc/network/interfaces ---

iface wlan0 inet dhcp
	wireless-essid	DLINK

auto wlan0

--- /etc/network/interfaces ---

And that should do it.  You don't need to specify the channel/frequency 
if your card can scan (which it can).  The wmaster0 interface is totally 
unnecessary in your case. :)



More information about the ubuntu-users mailing list