Synaptic Error further info

Dale Hamilton dale at birramirra.com
Fri Jan 5 03:43:34 UTC 2007


I tried doing a force remove of this package but that also failed.
Result as follows:

root at desktop:/home/dale/Desktop# dpkg --remove --force-remove-reinstreq
dcp8020lpr
dpkg - warning, overriding problem because --force enabled:
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
(Reading database ... 102311 files and directories currently installed.)
Removing dcp8020lpr ...
/var/lib/dpkg/info/dcp8020lpr.postrm: 3: /etc/init.d/lpd: not found
dpkg: error processing dcp8020lpr (--remove):
 subprocess post-removal script returned error exit status 127
Errors were encountered while processing:
 dcp8020lpr

If I try to use apt-get i get the same error as synaptic:

root at desktop:/home/dale/Desktop# apt-get install dcp8020lpr
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package dcp8020lpr needs to be reinstalled, but I can't find an
archive for it.



On Fri, 2007-01-05 at 12:52 +1100, Dale Hamilton wrote:
> I recently tried installing a driver for my printer.
> 
> Now when I try to open Synaptic I get the following error:
> 
> E: The package dcp8020lpr needs to be reinstalled, but I can't find an
> archive for it.
> E: Internal error opening cache (1). Please report.
> 
> I am unable to proceed further.  I have tried googling for info about
> this error but can't find anything.
> 
> I am using ubuntu 6.10
> 
> Thanks, Dale.
> 
> 





More information about the ubuntu-users mailing list