Unable to capure more than one image in Dapper 6.06

Mark Barton mark at atldes.com
Wed Jan 3 22:57:26 UTC 2007

I have been using a CLI program call videodog 
to capture single frames from a Avermedia Eyes Pro card (Bt878 based) 
with Suse 10 (2.6.13 kernel). This worked great fine until I  recently 
switched to Ubuntu Dapper 6.06. (2.6.15 kernel). I can capture a good 
frame if my computer is first powered on, however all subsequent 
captures only show a white image with absolutely no detail at all. Now 
if I run Tvtime or Xawtv I can get a continuous image stream, but if I 
then attempt a capture using the videodog program, I will get one good 
image and then nothing but white images after that. I also tried a 
program called streamer that was in the Ubuntu repositories and it gave 
the same results. I did try v4lctl and fiddling with some of the 
control, but that didn't work either.

I feel that this is a setting or perhaps something was added to the 
driver that is not initialized correctly in the older CLI programs 
although I did look at the boot log messages and both SUSE and Ubuntu 
are using the same bttv driver version.

 From dmesg...
[17179605.800000] bttv0: Bt878 (rev 17) at 0000:00:14.0, irq: 10, 
latency: 32, mmio: 0xde003000
[17179605.800000] bttv0: using:  *** UNKNOWN/GENERIC ***  
[17179605.800000] bttv0: gpio: en=00000000, out=00000000 in=008ff002 [init]
[17179605.896000] bttv0: using tuner=-1
[17179605.896000] bttv0: i2c: checking for MSP34xx @ 0x80... not found
[17179605.900000] bttv0: i2c: checking for TDA9875 @ 0xb0... not found
[17179605.900000] bttv0: i2c: checking for TDA7432 @ 0x8a... not found
[17179605.904000] bttv0: i2c: checking for TDA9887 @ 0x86... not found
[17179605.904000] bttv0: registered device video0
[17179605.904000] bttv0: registered device vbi0

. I would appreciate it if someone  and can point in the right direction 
for troubleshooting the problem. I certainly don't might digging down 
into application or driver code if necessary

Motherboard - VIA ME6000, 600 MHZ, 1GB memory


More information about the ubuntu-users mailing list