no USB in Edgy [SOLVED] <-- needed a custom kernel

Rutger van Haasteren vhaasteren at
Wed Jan 3 08:40:09 UTC 2007

Yes, you are right that I haven't solved any problems. I should have said
that there is something in the kernel that makes it refuse to work with USB
on my box. I didn't intend to indicate that my problem was very critical,
since for the majority of the users it works. But it is something important
enough that it should be looked at. And since I am the only one having this
problem, that person should be probably be me. With suggestions from
experienced kernel people, since that obviously doesn't include me.

I will not be (continuously) connected to the internet for the next few
weeks however, but after that I will surely dive into the problem. Still
strange however that it's even enough to make a vanilla kernel with the
original .config setup file. Do you/anybody have any suggestions on what to
try in the mean time?


On 1/2/07, Derek Broughton <news at> wrote:
> Rutger van Haasteren wrote:
> > My configuration is not that unusual. As a matter of fact I have a very
> > common mainboard/cpu/memory setup. Still the live CD of Edgy does not
> > enable me to use USB whereas the dapper/breezy Ubuntu or whatever distro
> > does make the USB work. Even a dapper kernel on Edgy makes the USB
> devices
> > work. And a custom vanilla kernel also solves the problem. I don't see
> how
> > this can be something unusual about my setup. Every other distro, and
> also
> > MS Windows, 'just works' which should also be the case with Ubuntu. The
> > standard Ubuntu kernel should support as much hardware as possible, and
> at
> > least as much common hardware as the previous versions.
> >
> > So in my opinion it really IS a big deal if USB is not working for
> 'some'
> > of us when it did with previous versions. It doesn't matter if I can
> solve
> > the problem,
> of course it matters - however, you haven't solved any problems, you've
> just
> sidestepped them.
> > some other people might not know this and will not pick
> > Ubuntu for that reason (although Dapper is still recommended). So I did
> > file a bug report at launchpad.
> >
> > My Setup
> > Mainboard: MSI RS480 M2-IL (Socket 939)
> > Processor: AMD 64 3200+
> > Videocard: onboard
> > Memory: 1 GB TwinMos
> > PCI USB add-on: 1x Sweex PCI USB 2.0 (there are also 2 onboard USB
> inputs,
> > also do not work)
> >
> I don't disagree that it's serious, but I get right ticked when people
> insist that their problem is clearly critical, when it's not a problem for
> practically everybody else.  That makes it either user error or an unusual
> setup.  In either case, the solution is not "make a custom kernel",
> it's "figure out what's different between my setup and everybody else's" -
> then we can fix it.
> --
> derek
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list