error downloaning

Jeffrey F. Bloss jbloss at tampabay.rr.com
Tue Jan 2 18:38:22 UTC 2007


dave L wrote:

> William Biggs wrote:
> > I got a new pc I put ubuntu on here but when I try to download
> > w32codecs only this it donload the index.html file any ides ? Can
> > someone send me a link so I can download them ?
> > wget -c 
> http://www.debian-multimedia.org/pool/main/w/w32codecs/w32codecs_20060611-0.0_i386.deb
> 
> Try downloading it using your browser, that will propably work.
> 
> AFAICT wget uses HTTP/1.0 to make the request and the selection of
> the virtual host on the server side seems to fail resulting in a
> flase redirection. Using a client which generates requests conforming
> to HTTP/1.1 should work - as said above.

I'm wondering if the problem here isn't the -c switch? I missed the OP
but I know wget can behave oddly in some scenarios when trying to force
a continuation if the remote server doesn't support them, files have
changed, etc. Wget defaults to continuing aborted downloads anyway I
believe, and it almost makes sense that if you tried to force them it
would dutifully save any error messages issued on the remote end. Which
could of course be HTMLized versions of of "unable to comply" messages
automagically generated as an index.html.

In any case I tried the download here and it works a treat with or
without the -c switch even after I manually truncated a few bytes from
the end of a completed download. But if, as you said, there's a
revolving pool of mirrors or any odd redirection going on this could
change from download to download.

Wget version 1.10.2 FWIW...

-- 
     _?_      Outside of a dog, a book is a man's best friend.
    (o o)         Inside of a dog, it's too dark to read.
-oOO-(_)--OOo-------------------------------[ Groucho Marx ]--
    grok!              Registered Linux user #402208
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 892 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20070102/a094235d/attachment.pgp>


More information about the ubuntu-users mailing list