no USB in Edgy [SOLVED] <-- needed a custom kernel

Rutger van Haasteren rvhaasteren at
Mon Jan 1 20:45:03 UTC 2007

My configuration is not that unusual. As a matter of fact I have a very
common mainboard/cpu/memory setup. Still the live CD of Edgy does not enable
me to use USB whereas the dapper/breezy Ubuntu or whatever distro does make
the USB work. Even a dapper kernel on Edgy makes the USB devices work. And a
custom vanilla kernel also solves the problem. I don't see how this can be
something unusual about my setup. Every other distro, and also MS Windows,
'just works' which should also be the case with Ubuntu. The standard Ubuntu
kernel should support as much hardware as possible, and at least as much
common hardware as the previous versions.

So in my opinion it really IS a big deal if USB is not working for 'some' of
us when it did with previous versions. It doesn't matter if I can solve the
problem, some other people might not know this and will not pick Ubuntu for
that reason (although Dapper is still recommended). So I did file a bug
report at launchpad.

My Setup
Mainboard: MSI RS480 M2-IL (Socket 939)
Processor: AMD 64 3200+
Videocard: onboard
Memory: 1 GB TwinMos
PCI USB add-on: 1x Sweex PCI USB 2.0 (there are also 2 onboard USB inputs,
also do not work)


On 12/31/06, Derek Broughton <news at> wrote:
> Rutger van Haasteren wrote:
> > Since nobody responded I guess I am alone in this, but I solved the
> > problem anyways. I took a kernel from and
> compiled
> > it for my system. Everything works now, including all my USB devices...
> > Strange that nobody else has had this problem. It really is a problem
> with
> > the stock Edgy kernel...
> >
> No, it really isn't.  There may be something unusual about your
> configuration, but USB is working for most of us.
> --
> derek
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list