Fwd: hp dv9540 laptop second harddrive not detected

James Takac p3nndrag0n at gmail.com
Wed Aug 29 10:42:44 UTC 2007

On Wednesday 29 August 2007 18:14:43 Niels Larsen wrote:
> ----------  Forwarded Message  ----------
> Subject: Re: Fwd: Re: Fwd: Re: Fwd: hp dv9540 laptop second harddrive not
> detected
> Date: Wednesday 29 August 2007
> From: James Takac <p3nndrag0n at gmail.com>
> To: "Ubuntu user technical support, not for general discussions"
> <ubuntu-users at lists.ubuntu.com>
> On Wednesday 29 August 2007 11:42:10 Niels Larsen wrote:
> > K then. try
> >
> > sudo update-initramfs
> >
> > seems I 4got one keystroke
> > ***
> >
> > I tried that: sudo update-initramfs -u
> >
> > It worked once, and I added the piix to the /etc/modules
> >
> > after that it did not work anymore.
> >
> > I think piix has something to do  with cd-rom (I googled after it)
> Hi Neils
> U edited /etc/modules as root? To my knowledge that should ensure the piix
> module is loaded after rebooting. may post you /etc/modues file? And I see
> u figured out the switch I forgot about as well
> ***
> Here is the contents of my /etc/modules:
> lp
> sbp2
> piix
> ***
> That it worked at all seems a good sign that the prob is driver related and
> related to the prob with libata as was pointed out earlier on the list when
> I was going thru this with my sata dvd drive. It may be that u'll also have
> to edit fstab? Not sure there
> ***
> I have edited /etc/fstab, but "sda and sda1"  does not exist in /dev (only
> the few times sdb1 has worked properly, after my formatting it with gparted
> and then once, I told about after I tried your instructions?
> ***
> James
> --
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
> -------------------------------------------------------

Hi Neils

Then sdb1 would appear to be the drive when it is working. Been doing a lil 
more searching and have found some instances of bios settings when set wrong 
giving a hit and miss affair as it were with the drive. Beyond possible bios 
settings, I'll admit to being at a loss. That my idea got somw sucess 
suggests we're on the right path so to speak. Or how about your /etc/fstab 
file? Are there any lines that pont to sdb1? Can u 

sudo mount /dev/sdb1


Trying to remember the cat command that tells us which drives are recognised. 
Maybe someone else can help there?

Another quick thought. If repeating the instructions gets the drive recognized 
again, try right clicking on the icon for the drive and getting the details 
from its properties. Can't hurt.

am trying to google for your your prob as well, i.g. search something 
like "ubuntu feisty cant mount sata drive" assuming u'r using feisty. Try an 
number of variations on the theme of course.

I'll try and look further, but I suspect it's a variation on the prob I had. 
Would definately suggest to check your bios settings as well. What options r 
available for the drive in Q?


More information about the ubuntu-users mailing list