SANE and the Epson Perfection 2450 on USB

Jack Bowling jbinpg at shaw.ca
Sun Aug 19 20:13:46 BST 2007


On Sun, Aug 19, 2007 at 02:58:12PM -0400, Alex Janssen wrote:
> I've been reading a lot of messages and fiddling with this for quit a 
> while and still cannot get it to work.
> 
> scanimage -L reports:
>      device `epson:libusb:001:003' is a Epson GT-9700 flatbed scanner
> If I run scanimage -L first thing after a reboot it reports instantly.  
> When I run it a second time it takes 30 seconds to report.  Don't know 
> what that means.
> 
> scanimage >image.pnm reports after 60 seconds:
>     scanimage: sane_start: Error during device I/O
> 
> Does anybody know how to get this working?

Alex - I have the same scanner and the same problems. My issues go away
totally if I put the scanner on my USB v1.1 bus. If I put it on the USB
v2.0 bus, it kacks. I suggest the USB implementation of this scanner is
borked so badly that it does not play well with the latest Ubuntu USB
implementations. Having said that, I bet one day some coder somewhere will
find a bug in udev and/or libusb that was the showstopper. Just do a Google
search "SANE Perfection 2450" and you can get all the gory history.

Jack 
 




More information about the ubuntu-users mailing list