Hard disk errors, fixable??

Bart Silverstrim bsilver at chrononomicon.com
Tue Aug 14 13:32:19 UTC 2007

GyroTech wrote:
> Hi all. I noticed recently  that if I tried to read a certain file from 
> my Ubuntu file server, the entire machine would seize up and become 
> unresponsive... X wouldn't respond and I couldn't switch to a console 
> terminal on any of the ctrl+alt+F1-5 keys. Nor would SSH allow me into 
> the box. The only thing to do was a hard reboot.
> I unmounted it and forced a file check with sudo fsck.ext3 -fcv 
> /dev/lvmhd/lvmhd1
> but after a long while the system hung up again and it had to be 
> rebooted. I can only assume the bad block checker hit the same bad area 
> but failed to work things out.
> After rebooting I checked dmesg and noticed this repeating result at the 
> tail...
> hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
> [17182718.676000] hda: dma_intr: error=0x40 { UncorrectableError }, 
> LBAsect=98085800, sector=98085800
> [17182718.676000] ide: failed opcode was: unknown
> [17182718.676000] end_request: I/O error, dev hda, sector 98085800
> hda is indeed one of the drives in the lvm array.
> The system works stable and fine as long as I don't access that one file 
> so I don't think it's anything wrong with any other bit of hardware.
> Are there any suggestions any has to further diagnose or even fix my 
> problem??

My personal advice is to get the drive replaced.  The drive's 
electronics should have already tried fixing the bad spot and marking 
that as unusable if the drive could hide it from you.  When I start 
seeing the "DriveReady SeekComplete Error and UncorrectableError 
statements from the kernel, it usually means the drive is going to die 
on you, and now's the time to back up the files ASAP (especially if it's 
currently happening when accessing one particular file).

More information about the ubuntu-users mailing list