x server not working

Tod Merley todbot88 at gmail.com
Wed Sep 13 13:41:57 UTC 2006

On 9/5/06, Saurabh Moghe <moghe.saurabh at yahoo.com> wrote:
> Hi,
> I have installed Ubuntu Breezy on my Intel PC. Then i upgraded it to Ubuntu
> Dapper. It worked fine the first day. The next day when I tried to boot in
> Ubuntu it gives me an error that the X server is not working. I tried to
> reinstall xserver-xorg, but that did not work out.
> Can anyone help me on this.
> Thanks in advance.
> Saurabh.
> --
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Hi Saurabh!

There is a file in /var/log called Xorg.0.log.  You should drop to a
simple shell when you boot Ubuntu without X, or you can use any live
CD to obtain a shell.  Observe this file (especially the end of this
file) and note any "WW" (warnings) and "EE" (why I died).  This should
tell us why X could not start.

It would also be good to obtain and use KNOPPIX as it is pretty good
with hardware.

Then copy /etc/X11/xorg.conf to say /etc/X11/xorg.conf.today (command
would be "sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.today").
While booted into KNOPPIX copy the file and put it on a flash drive or
mount your drive and save it there (must mount it read write).

Very helpful in this would be a copy of the video card and monitor
technical specifications.

Look at the "monitor" and "display" sections and match what the log
file tells is the problem is the basic procedure to correction.

Good hunting!


More information about the ubuntu-users mailing list