USB mounting/ troubleshooting [was Re: help needed]

Peter Garrett peter.garrett at
Tue Sep 5 12:14:27 UTC 2006

On Mon, 4 Sep 2006 23:07:31 +0500
"Waqas Toor" <waqasnasirtoor at> wrote:

> hi guyz
> sorry to disappoint you but i tried a lot but could mount my usb
> tried lsusb got the device ids of the usb ports but nothing happened
> there is no device /dev/sda1 etc
> so i guess i dont have the drivers for the the usb in my laptop
> laptop is inspiron 2500 dell
> what could be i missing here ... i tried every option in this thread :-(

I suggest you try the following:

* Open terminal and type

tail -f /var/log/messages  


* Plug in your USB

see what appears in the terminal  ( tail -f is useful because it leaves
the file open and updates the output as it happens )

You will see weird stuff like: ( these lines are wrapped here because they
are quite long - I suggest maximising your terminal for better readability
when you try it)

Sep  5 21:42:32 localhost kernel: [32388.635909] usb 4-1: new high speed
USB device using ehci_hcd and address 3 Sep  5 21:42:33 localhost kernel:
[32389.204287] Initializing USB Mass Storage driver... Sep  5 21:42:33
localhost kernel: [32389.205661] scsi0 : SCSI emulation for USB

The relevant bit is the part that looks like

 sda: Write Protect is off
Sep  5 21:42:38 localhost kernel: [32394.376895]  sda: sda1

this tells you it is sda1

* To double check, type in another terminal 

dmesg | tail 

look for something like

[32394.376096] sda: assuming drive cache: write through
[32394.376895]  sda: sda1

Again, clearly this device is at sda1 - note that the /dev/  directory is
not permanent any more but is generated dynamically  ( udev , hal ,
gnome-volume-manager and friends )

* If you don't see your file manager pop up, and there is no "special
name" icon in /media  ( mine mounts as  /media/usbdisk in the example
above ) , then you have a manual option: the "pmount" command, which
allows users to mount removable devices. ( pumount to unmount )

You can also mount in the old way, but the problem with this is that which
device ( sda1, sda2 etc) is assigned depends on the order that they are
plugged in - so the same drive can have different /dev/  positions at
different times. You can write your own udev rules to overcome this, but
that is a whole subject in itself

Notice that as soon as the device is "ejected" ( unmounted in the
new-fangled manner for such devices ) the system will immediately forget
that it exists ;-) This can be a bit confusing since it is still
physically plugged in !

There is also a tool called "ivman" which can be used if the gnome ones
fail - for instance I tried it in fluxbox . I'm not sure whether this is
what KDE uses for automagic mounting.

It's all very different from the old static way, but if you read about the
commands and concepts it might help ( I did this some time ago when I was
puzzled by the way things appeared and disappeared, even though they were
still attached!)

Oh - COM 1 is /dev/ttyS0  COM 2 is /dev/ttyS1   and so on .... ( I think
you also asked about that )


More information about the ubuntu-users mailing list