AVerMediaTV Hybrid+FM Volar

Eohaid Bres McElatha bres_sidhe at drouland.com
Fri Nov 24 22:00:16 UTC 2006


Hi, 

I've AverMedia AverTV Hybrid+FM Cardbus.  I installed driver (downloaded from 
website AverMedia) for SuSE 10.

# alien AVerMedia-MTSA-SUSE10-0.36Beta-1.i386.rpm
Warning: Skipping conversion of scripts in package AVerMedia-MTSA-SUSE10: 
postinst postrm preinst
Warning: Use the --scripts parameter to include the scripts.
avermedia-mtsa-suse10_0.36Beta-2_i386.deb generated

# dpkg --install avermedia-mtsa-suse10_0.36Beta-2_i386.deb
(Reading database ... 113770 files and directories currently installed.)
Preparing to replace avermedia-mtsa-suse10 0.36Beta-2 (using 
avermedia-mtsa-suse10_0.36Beta-2_i386.deb) ...
Unpacking replacement avermedia-mtsa-suse10 ...
Setting up avermedia-mtsa-suse10 (0.36Beta-2) ...

# depmod -a
# modprobe saa713x
WARNING: Error inserting mt352: Invalid module format 
FATAL: Error inserting saa713x : Invalid module format
	
What problem? What I do not correctly?

-- 
Best regards,
	Eohaid "Bres Sidhe" McElatha
	Drou Land: The Cross-Roads
	Sat Nov 25 00:49:25 MSK 2006

E-Mail:	bres_sidhe at drouland.com
WWW:	http://www.drouland.com
ICQ:	48681586

Ubuntu 6.10 (edgy) with kernel 2.6.17-10-generic


On Saturday 25 November 2006 00:05, Stratos Laspas wrote:
> Hi there.
>
> The above mentioned tv usb stick is supposed to be compatible with linux.
>
> The customer support people were very helpful and fast in directing me
> to the correct driver download for linux.
>
> http://tinyurl.com/yjflfy
>
> That installer works with 6.06 LTS, however even in case it does not
> find the kernel it was built against, it builds a new one driver, so
> long as the kernel source is installed.
>
> From the help file:
>
> QUOTE
> 1.3 Tested Distributions
>
>     The following distributions are officially supported:
>
>     1. Open SuSE Linux 10.0
>     - kernel 2.6.13-15-smp, 2.6.13-15-default
>
>     2. Mandriva Linux 2006
>     - kernel 2.6.12-12mdksmp, 2.6.12-12mdk
>
>     3. Fedora Core Release 3
>     - kernel 2.6.9-1.667smp, 2.6.9-1.667
>
>     4. Fedora Core Release 4
>     - kernel 2.6.11-1.1369_FC4smp, 2.6.11-1.1369_FC4
>
>     5. Fedora Core Release 5
>     - kernel 2.6.17-1.2174_FC5smp, 2.6.17-1.2174_FC5
>
>     6. Debian 3.1
>     - kernel 2.6.8-3-686-smp, 2.6.8-3-686
>
>     7. Ubuntu 6.06 LTS
>     - kernel 2.6.15-23-686, 2.6.15-23-386
> UNQUOTE
>
> I run Edgy, so I installed kernel headers and the kernel source. Then I
> extracted the kernel source. However, in the directions is says:
>
> QUOTE
> If the installer have to rebuild driver to support updated or customized
> kernel, kernel source must be available or installer will not work. If
> unsure, check if there are C header files (*.h) under this directory:
>
> # ls /lib/modules/`uname -r`/source/drivers/media/dvb/dvb-core/
> UNQUOTE
>
> In that directory, I have only "Kconfig" and "Makefile"
>
> When I run the installer, it fails and I want to rule out the
> possibility of something that I do wrong about the kernel source.
>
> The message from the installer is:
> > $ sudo sh ./AVERMEDIA-Linux-A828-0.03-beta.sh
> > ./AVERMEDIA-Linux-A828-0.03-beta.sh: 24: [[: not found
> > Verifying archive integrity...
> > ./AVERMEDIA-Linux-A828-0.03-beta.sh: 33: [[: not found
> > Extracting archive...
> > ./AVERMEDIA-Linux-A828-0.03-beta.sh: 42: [[: not found
> > Invoke installer...
> > # # # # # # # # # # # # # # # # # # # > > ./installer.sh: 21: [[: not
> > found # # > > ./installer.sh: 25: [[: not found
> > # # # > > ./installer.sh: 30: [[: not found
> > # # > > ./installer.sh: 34: [[: not found
> > # # ./installer.sh: 36: let: not found
> > # ./installer.sh: 37: let: not found
> > # # > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > # # >
> > > > > # # > > > > > > # # > > > > > > > > > > > > > # # > > > > > > > > #
> > # > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > >
> > > > > > # # > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > >
> > > > > > > > > ./installer.sh: 229: Syntax error: Bad for loop variable #
> > > ./installer.sh: 230: e: not found
> > #
> > #
>
> If it's not the kernel, then I can go back to the support desk and ask
> for new directions. Any hints would be welcome.
>
> Thanks,
>
> Stratos

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20061125/03cd465d/attachment.pgp>


More information about the ubuntu-users mailing list