Can't get into sudo - HELP!

Ed Smits ed.smits at
Sat Nov 18 03:24:38 UTC 2006

I'm a relatively new UBUNTU user, using Dapper. My laptop has a NIC
and a WiFi card, both work. NIC is set for fixed IP at the office,
WiFi is set for DHCP. I haven't yet figured out hardware profiles, so
my solution has been to disable the WiFi at work and reverse this at

Got home today, turned on the laptop, took forever to boot. Tried to
start the Network app to switch to the WiFi card, nothing happened.
After many false starts I opened a terminal and tried to run something
as sudo, got the following error:

sudo: unable to lookup hostname via gethostbyname()

hostname being my correct unqualified hostname.

I opened my hosts file and see only 2 entries (besides the IPv6 ones) localhost localhost

Having more experience with Fedora (but not much more) I figured no
big deal, I'll log in as root and fix this, of course I don't have
root logins enabled...

I went to the rootsudo FAQ at Ubuntu, tried to follow their suggestion
to go to another terminal window, log in as myself, do a sudo -i and
then startx -- :1 to get a graphical login as root so I could fix my
problem. No go, same gethostbyname error when I sudo.

1) how do I get in to my system without going back to the office where
I assume the problem will not affect me
2) what should my hosts file contain if that is the problem?

Hope someone can help on this


More information about the ubuntu-users mailing list