Can't print to CUPS from WinXP

Mitch Contla mcontla at
Fri Nov 17 19:35:48 UTC 2006

Jens Cedlind said the following on 11/17/2006 08:40 AM:
> Hi,
> I've set up CUPS on one machine (running Edgy), and I can print from 
> both the machine the printer (an old HP LaserJet 4L) is connected to, 
> and from other Edgy machines on my home network.
> The problem comes when trying to print from WinXP machines, using both 
> the default driver Windows installs and the PostScript driver found on 
> HP website.
> It's set up to allow connections from, 10.0.0.*.
> access_log shows:
> - - [17/Nov/2006:17:08:37 +0100] "POST /printers/LaserJet-4L 
> HTTP/1.0" 200 35795 Print-Job client-error-not-possible
> for each tried printjob and multiple
> - - [17/Nov/2006:17:09:04 +0100] "POST /printers/LaserJet-4L 
> HTTP/1.1" 200 185 Get-Jobs successful-ok
>  From this, it seems to me that the client can connect and get queue 
> info ok, but when it tries to print, CUPS doesn't understand the data 
> sent. (Wild guess on my part)
> I've googled high and low for a few hours now, and only relevant info, 
> was that this might happen if there was no quota set.
> I tried setting quota to 100 pages during 1 hours, no sizelimit.
> cups error_log shows nothing.
> I've tried using both http:// and ipp:// as printer URIs, both without 
> any luck.
> The admin pages and printer info etc can be access fine from the WinXP 
> machines.
> It should be mentioned that I'm *not* running Samba on the computer, 
> although most guides out there tells you to set up both. I really don't 
> find it relevant when using the IPP/HTTP protocols for printing.
> Please correct me if I'm just stubborn and wrong :p
> ty in advance,
> Jens Cedlind
> PS: sorry if it's a tad out of bounds for this list.
I have never had any problems printing from a Win2000/XP box to Ubuntu
without samba. I am currently running Dapper and setup my Win printers
using the steps I posted in the Ubuntu forums:

I have occasionally had some problems with driver variations (especially
PCL), but the stock HP PS driver has always worked.

Could you provide some more details on your configuration?


More information about the ubuntu-users mailing list