file with no name -- cannot be deleted

Barry barrynyc at
Mon Nov 6 11:49:28 UTC 2006

On 11/6/06, Eamonn Sullivan <eamonn.sullivan at> wrote:
> On 11/6/06, Barry <barrynyc at> wrote:
> > I tried find with -inum -exec rm and received the error that the
> > directory was not empty.
> >
> > It's a separate ext3 partition, so I unmounted it and ran fsck and am
> > told it's clean. Wouldn't that be equivalent to running off the live
> > cd?
> Yes, that's the same as running from the live CD. Silly question, but
> did you try ls -a? The 'a' option shows files that begin with a dot. I
> didn't see that among the things you tried.
> -Eamonn

I did and it shows up as what looks like a nonprinting character:

$ ls -a yyy
   .  ..

But it seems to be an empty string.  In the  python interpreter, I got:

>>> os.listdir('yyy')

By the inodes, the directory yyy and the single item in it, this
unnamed file or whatever, are the same thing.

In the end, I suppose I could simply back up the partition, and put a
new filesystem on it.

More information about the ubuntu-users mailing list