Wireless Help

Peter Brook drpeter.brook at btinternet.com
Sun Nov 5 10:19:36 UTC 2006

"Michael R. Head" <burner at suppressingfire.org> wrote: On Wed, 2006-10-25 at 23:09 +0100, Peter Brook wrote:
> Hi to you all
> I have struggled to get an Advent 7039 laptop running Ubuntu 6.10 for
> AMD 64 working on either it's internal Wifi card, or a USB one that
> worked OK with Kubuntu 6.06

Hi. You may be experiencing trouble due to the conflict of the newly
introduced prism2 drivers which don't seem to support the hardware well.

Here's the bug report: 

Try this:
sudo modprobe -r orinoco_pci
sudo modprobe -r prism2_pci
sudo modprobe -r hostap_pci
sudo modprobe orinoco_pci

And consider blacklisting prism2_pci (and perhaps prism2_usb?)


> I have tried going through the WIKI documentation on wireless cards
> including the troubleshooter.  My wireless card is a Intersil (Prism)
> 3890.  It is identified by Ubuntu at install and Prism 54 driver
> loaded.  However, it fails to connect.  I also tried to use the
> windows driver and NDSIWRAPPER, but that came up with the error
> message that the incorrect dirver was being used!
> The laptop has "Launch keys" one of which under windows starts the
> wireless card.  I have searched internet to try and find a method of
> launching wireless card or activating  Launch Keys  under Ubuntu, but
> with no success.  The BIOS will only let me set the wireless card
> default as off, or to resume to the state when last shut down, not to
> automatically initiate. 
> I think the USB wireless (ADDON) has now fried itself.  It used to be
> identified within the USB settings, but now is not.  Neither is it
> identified on what I hope will become my legacy windows machine...
> My Ubuntu experience is very limited, but I am keen to learn.  If
> anyone can guide me to self-help further, that would be great.  If
> anyone that can help, but needs more information, tell me in simple
> terms and I will try and send.
> As an alternative, could anyone recommend a PCMCIA card that will work
> on 6.10 Ubuntu for AMD 64 without any great set-up knowledge needed -
> or direct me to a suitable listing?    Although I almost feel like it
> is giving up, I would like to get the wirelsse sorted and start to
> move onto other things even if I have to invest in a little more
> hardware.
> Thanks in anticipation and what a great forum!  It is just so
> embarassing that I ask for help, but am way of the skill level of
> giving any back.
> Peter Brook 
> drpeter.brook at btinternet.com   
Michael R. Head 

ubuntu-users mailing list
ubuntu-users at lists.ubuntu.com
Thanks for suggestion.  Entered in terminal, but still no success.

 The output from lspci -v includes the following:-

00:0a.0 Network controller: Intersil Corporation ISL3890 [Prism GT/Prism Duette]/ISL3886 [Prism Javelin/Prism Xbow] (rev 01)
        Subsystem: Z-Com, Inc. XG-600 and clones Wireless Adapter
        Flags: bus master, medium devsel, latency 80, IRQ 193
        Memory at d0000000 (32-bit, non-prefetchable) [size=8K]
        Capabilities: [dc] Power Management version 1

As mentioned, the Advent 7039 has launchkeys including one for the wireless card, but I have been unable to activate these as yet.  The BIOS only allows me to set the card as inactive, or resume previous state, not to automatically active at boot.
 Could someone confirm that the above output indicates that the card is not activated?
 If this is the case any suggestions on how I might activate the card, or trigger the launchkeys?  


drpeter.brook at btinternet.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20061105/7eb46c41/attachment.html>

More information about the ubuntu-users mailing list