Edgy issues on my X40 thinkpad

Jaime Davila jdavila at hampshire.edu
Fri Nov 3 20:03:34 UTC 2006

Hello all,

Since upgrading to edgy a couple of days ago, I've found a couple of 
issues that I would like to mention, in the hope that either: 1) someone 
has figured these out or, 2) I can be pointed towards the appropriate 
place to file a bug report.

I've looked online, on google, in the ubuntu forums, and the ubuntu wiki 
pages, but haven't found a solution yet.

I have an IBM X40 thinkpad. I was running dapper without problems. 
Everything was working great (hibernating, suspending, USBs, wireless, 
base station).

My graphics card chip set is the 855 kind.

I upgraded to edgy by editing my sources.conf file, apt-get update, 
apt-get dist-upgrade.

Many things now continue to work fine. For example, I can still 
hibernate and suspend, the wireless card works. In fact, I can only 
detect one problem, which seems to have to do with xorg.

If I boot outside the base, and then plug the base in, x deals with it 
fine, except that the cursor is displayed all distorted, to the point 
that it is close to invisible most of the time. I've tried changing the 
cursor set that's being used, but all of them look distorted. If I click 
on the undock button of the base while the cursor is distorted like 
that, the laptop locks hard, and I need to do a hard reset.

If by any chance the screen goes off, and then I turn it on, all of this 
disappears. That is, the cursor looks good, and I can undock without a 
problem. So, if I suspend and then come back up, I'm good. Since I have 
my screen saver set to turning the screen off, if the screen saver comes 
on, I'm good. If I press fn-f3, to blank the screen, I'm NOT good.

I should add that if I boot on the base with a CRT attached, the 
situation with the screens and the distorted cursor gets reversed. The 
cursor is fine on the CRT, but if I switch to the LCD I get a distorted 
cursor. Forcing the screen off and back on solves the issue.

One more thing: after the initial upgrade to edgy the GUI wasn't coming 
on. After looking at the xorg log file I ended up apt-getting 
xserver-xorg, and that solved the problem.

Any leads are appreciated.




Jaime J. Davila
Associate Professor of Computer Science
Hampshire College
School of Cognitive Science
jdavila at hampshire dot edu

More information about the ubuntu-users mailing list