bluetooth - how to pair phones

Marius Gedminas marius at pov.lt
Wed Nov 1 13:29:33 UTC 2006


On Wed, Nov 01, 2006 at 02:38:44AM +0200, Dimitri Mallis wrote:
> dimitri at ubuntu:~$ hcitool scan
> Scanning ...
>        00:0F:DE:BB:7E:F0       K700i
> dimitri at ubuntu:~$ sudo hcitool cc 00:0F:DE:BB:7E:F0
> dimitri at ubuntu:~$ sudo hcitool auth 00:0F:DE:BB:7E:F0
> HCI authentication request failed: Input/output error
> dimitri at ubuntu:~$
> 
> well it just wont let me enter a code to pair the phone, no matter how many
> times i run sudo hcitool auth 00:0F:DE:BB:7E:F0
> 
> i can send & recieve files but can use any syncronise software which is what
> i want to use
> 
> im using edgy

I saw a couple of bug reports in launchpad about Bluetooth pairing being
broken.  That was quite some time before the release, and I hope these
were fixed.

Last time I attempted Bluetooth pairing was in Dapper.  I had to run

  sudo /etc/init.d/bluez-utils restart

in a GNOME Terminal so that the the bluetooth daemon would inherit my
shell evironment ($DISPLAY and $XAUTHORITY in particular), and after
that it would pop up a nice GUI PIN dialog for me, automatically, when I
tried to initiate pairing from the phone.

I now that the init script was renamed to /etc/init.d/bluetooth in Edgy.
I think the PIN infrastructure was also changed to use dbus or
something, and shouldn't need the hack I had to use in Dapper any more.

I've never used hcitool cc/auth and I do not know how they work.

Marius Gedminas
-- 
If you want to trick a pointy-haired boss into letting you write software in
Lisp, you could try telling him it's XML.
                -- http://www.paulgraham.com/icad.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20061101/9f7dbf8b/attachment.pgp>


More information about the ubuntu-users mailing list