Problem installing Creative Webcam Live! Ultra

John Schofield schoflist at
Tue Mar 28 22:24:45 UTC 2006

I'm testing several webcams for my company. I'm running Ubuntu 5.10  
with all updates.

A Logitech QuickCam Pro 4000 showed up in GnomeMeeting with no  
problems -- worked flawlessly.

However, I'm having a little more trouble with Creative Webcam Live!  
Ultra. Which stinks, because its lens characteristics are better for  
our purposes.

Creative does not support Linux directly, but do point to a web page  
with pointers to open-source, non-Creative drivers:

Although my camera is not listed, the closest match seemed to be the  
Spca5xx project at:

They list several Creative cameras, including one "Live!" one, but  
not the Ultra.

Because it seemed like a close match and *might* work, I downloaded  
their package and attempted to install it.

Their instructions say you need to have a kernel source tree:

"Module compile outside the kernel tree but need the source of your  
kernel installed and configured.
be sure your kernel include usb and v4l stuff"

So I ran "apt-get install kernel-package-2.6.12-10" and then  
"fakeroot make-kpkg --revision=bogus.0 kernel_image"

When I run "make" from inside the "spca5xx-20060301" folder, I get  
the following output:
"Building SPCA5XX driver for 2.5/2.6 kernel.
    Remember: you must have read/write access to your kernel source  
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/dakim/ 
spca5xx-20060301 CC=cc modules
make: *** /lib/modules/2.6.12-10-386/build: No such file or  
directory.  Stop.
make: *** [default] Error 2"

My questions:

1) Am I doing this the right way? Is there a better way of getting  
this camera working with Ubuntu?
2) Would Dapper have better support for my camera?
3) If I'm going about this the right way in general, what am I  
missing when I attempt to compile the spca5xx driver?

Thanks very much!

More information about the ubuntu-users mailing list