Java compatibility? (was Re: Not a bash, just the facts)

Derek Broughton news at pointerstop.ca
Mon Mar 27 02:00:26 UTC 2006


Matthew R. Dempsky wrote:

> On Sun, Mar 26, 2006 at 04:38:11PM +0200, Alan McKinnon wrote:
>> With Java there's a trade-off with being able to run the same code
>> across many platforms, and backwards compatibility. An app coded to
>> 1.4.2 will run on any 1.4.2 compliant VM *or later*.
> 
> If 1.5 is available and will run 1.4.2 code, then why would people fuss
> about wanting to use 1.4.2?

They shouldn't, but I've seen plenty of examples of organizations that
simply don't trust any software that isn't already 3 years old (ie,
obsolete).
-- 
derek





More information about the ubuntu-users mailing list