PCI: multiple domains not supported

Jason Straight jason at jeetkunedomaster.net
Tue Mar 14 20:48:11 UTC 2006


Sorry for the cross post but this may pertain to dapper too.

Trying to install breezy on a new HP dual opteron system I get as far as the 
kernel message:
PCI: Multiple domains not supported

According to the only informative article I could find on this:
http://archives.mandrivalinux.com/cooker/2006-02/msg02462.php

From the Mandriva post:
Installation fails on systems that have multiple PCI domains on the mainboard.
The reason is that there has been no support in the 'stock' linux kernel for 
the x86 arch until recently.

Support for multiple PCI domains on the x86 architecture is needed for 
compatibility with current and future computer mainboards.

Background, available fixes, etc:

Multiple PCI domains are also known as segments by ACPI. These are used by 
newer mainboards for support of the multiple types of PCI bus that now exist 
on 
the x86 arch, including the PCIe (which is not a real bus).

[SNIP]

However, note that (k)Ubuntu uses the single CPU kernel for initial 
installation and it failed also with the same error for both 32 & 64-bit 
versions of the 'hoary' and 'breezy' releases.
On the other hand, I also tried a "live" SuSE DVD, which uses a non-smp 
kernel, 
and it runs in much the same way as the CentOS, i.e., good but in a reduced 
capacity.

Support for multiple PCI domains for the x86 arch is needed as soon as 
possible 
to insure compatibility for installation and use of this linux OS.

-- 
|
| Jason Straight
| SkyCon.net 231-627-3528
| Jabber: leejunfan at jabber.org
| ICQ: 1796276 / AIM: JasonRStraight
| MSN: glock21-45cal at hotmail.com / Yahoo: jasonrstraight
| 




More information about the ubuntu-users mailing list