libc6 dependency probl;em in dapper

Tony Arnold tony.arnold at manchester.ac.uk
Tue Mar 14 13:52:06 UTC 2006


Adam,

Adam Conrad wrote:

>>I've just tried doing a dist-upgrade on my dapper trial system that I've
>>not touched for several weeks. It's hit a problem in that libc6-i686 is
>>dependent on libc6 (=2.3.5-ubuntu17), however, libc6_2.3.6-0ubuntu9 is
>>actually installed.
> 
> 
> You've removed dapper from your sources.list at some point.

Nope, this is a virgin disk that has only ever had dapper installed on
it. The source file is all dapper.

> 2.3.6-0ubuntu9 is the version in dapper, and if you make sure dapper is
> actually in your sources.list, then "apt-get update" and "apt-get
> upgrade" (or "apt-get -f install" if you can't get out of the loop), all
> should be well again.

Tried the -f install option. That asks to install libc6-i686 and
locales. Saying yes to this gives:

dpkg: error processing /var/cache/apt/archives/locales_2.3.11_all.deb
trying to overwrite '/usr/share/i18n/locales/en_AU', which is also in
package language-pack-en-base

Regards,
Tony.
-- 
Tony Arnold, IT Security Coordinator, University of Manchester,
IT Services Division, Kilburn Building, Oxford Road, Manchester M13 9PL.
T: +44 (0)161 275 6093, F: +44 (0)870 136 1004, M: +44 (0)773 330 0039
E: tony.arnold at manchester.ac.uk, H: http://www.man.ac.uk/Tony.Arnold




More information about the ubuntu-users mailing list